Should I upgrade my Mac?



macOS 10.15 Catalina System Requirements

It will run on these machines:

MacBook (Early 2015 or newer)

MacBook Air (Mid 2012 or newer)

MacBook Pro (Mid 2012 or newer)


* If your machine is older than these models we advise upgrading to 10.13.6 "High Sierra" to maximize the support window on your older machine. Remember Mac upgrades are free.

See https://support.apple.com/en-us/HT201475 for upgrading to Mojave.

See https://support.apple.com/en-us/HT208969 for upgrading to High Sierra


Remember Apple has officially deprecated support for all Mac OS X and macOS versions below 10.13.6


Need more help?

Return to Exam4 support home

Contact Extegrity User Support